• The website will be temporarily unavailable next night. Reason are The hoster moves our account to another server. Unfortunately, this also has the disadvantage that the IP changes. Between 2 and 6 o'clock.
  • Please do NOT PM me for support. For login data or problems/questions not intended for the public use the "Your private forum".

Fixed UTF-8 bug

R

rfc0001

Well-Known Member
XenForo License
UTF-8 characters in the thread name cause errors with ST404 add-in...

Server error log
  • InvalidArgumentException: Received invalid UTF-8 for string column [request_string]
  • src/XF/Mvc/Entity/Entity.php:697
  • Generated by: Unknown account
  • Jan 3, 2019 at 12:05 PM
Stack trace
#0 src/XF/Mvc/Entity/Entity.php(575): XF\Mvc\Entity\Entity->_castValueToType('/forum/threads/...', 'request_string', 5, Array)
#1 src/XF/Mvc/Entity/Entity.php(505): XF\Mvc\Entity\Entity->set('request_string', '/forum/threads/...')
#2 src/addons/xenMade/ST404/Repository/ST404.php(48): XF\Mvc\Entity\Entity->__set('request_string', '/forum/threads/...')
#3 src/addons/xenMade/ST404/Listener.php(25): xenMade\ST404\Repository\ST404->save404('/forum/threads/...', 'XF:Error')
#4 [internal function]: xenMade\ST404\Listener::dispatcher_pre_render(Object(XF\Mvc\Dispatcher), Object(XF\Mvc\Reply\Error), 'html')
#5 src/XF/Extension.php(67): call_user_func_array(Array, Array)
#6 src/XF/App.php(2395): XF\Extension->fire('dispatcher_pre_...', Array, NULL)
#7 src/XF/Mvc/Dispatcher.php(278): XF\App->fire('dispatcher_pre_...', Array)
#8 src/XF/Mvc/Dispatcher.php(44): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\Error), 'html')
#9 src/XF/App.php(1934): XF\Mvc\Dispatcher->run()
#10 src/XF.php(333): XF\App->run()
#11 index.php(13): XF::runApp('XF\\Pub\\App')
#12 {main}

-------------

Previous InvalidArgumentException: Received invalid UTF-8 for string column - src/XF/Mvc/Entity/ValueFormatter.php:126
#0 src/XF/Mvc/Entity/Entity.php(693): XF\Mvc\Entity\ValueFormatter->castValueToType('/forum/threads/...', 5, Array)
#1 src/XF/Mvc/Entity/Entity.php(575): XF\Mvc\Entity\Entity->_castValueToType('/forum/threads/...', 'request_string', 5, Array)
#2 src/XF/Mvc/Entity/Entity.php(505): XF\Mvc\Entity\Entity->set('request_string', '/forum/threads/...')
#3 src/addons/xenMade/ST404/Repository/ST404.php(48): XF\Mvc\Entity\Entity->__set('request_string', '/forum/threads/...')
#4 src/addons/xenMade/ST404/Listener.php(25): xenMade\ST404\Repository\ST404->save404('/forum/threads/...', 'XF:Error')
#5 [internal function]: xenMade\ST404\Listener::dispatcher_pre_render(Object(XF\Mvc\Dispatcher), Object(XF\Mvc\Reply\Error), 'html')
#6 src/XF/Extension.php(67): call_user_func_array(Array, Array)
#7 src/XF/App.php(2395): XF\Extension->fire('dispatcher_pre_...', Array, NULL)
#8 src/XF/Mvc/Dispatcher.php(278): XF\App->fire('dispatcher_pre_...', Array)
#9 src/XF/Mvc/Dispatcher.php(44): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\Error), 'html')
#10 src/XF/App.php(1934): XF\Mvc\Dispatcher->run()
#11 src/XF.php(333): XF\App->run()
#12 index.php(13): XF::runApp('XF\\Pub\\App')
#13 {main}
Request state
array(4) {
["url"] => string(46) "/forum/threads/��disney-parks-presents-a-25..."
["referrer"] => bool(false)
["_GET"] => array(0) {
}
["_POST"] => array(0) {
}
}
 
au lait

au lait

Administrator
Staff member
XenForo License
Xf2.1?
 
au lait

au lait

Administrator
Staff member
XenForo License
I can't reproduce the error here! I have changed something and hope you can test it once. -> read conversation
 
Top